czwartek, 29 listopada 2012

Formuły tablicowe - sumowanie warunkowe w Excel

Zadanie polega na zsumowaniu tych wierszy kolumny A (zakres -> A1:A20) dla których w komórce z kolumny B występuje 1.


suma "na piechotę" "=SUMA(C1:C20)"
- w kolumnie C wpisujemy formułę A1*B1 i kopiujemy w dół
- wystarczy suma(C1:C20) i mamy wynik

suma.jeżeli "=SUMA.JEŻELI(B1:B20;1;A1:A20)"
- b1:b20 to zakres w którym szukamy
- 1 to to czego szukamy
- A1:A20 to co jest wynikiem

suma formułą tablicową "{=SUMA(JEŻELI(B1:B20=1;A1:A20;0))}"
suma.jeżli może zostać przepisana na formułę tablicową (zatwierdzaną CTRL + SHIFT + ENTER - stąd nawiasy sześcienne)

suma tablicowa - rozwiązanie optymalne - "{=SUMA(A1:A20*B1:B20)}"
- sposób najprostszy a więc wymnażamy by potem wszystko zsumować (zatwierdzamy CTRL + SHIFT + ENTER)

1 komentarz:

  1. Przykład fajny tylko, że... niewiele mówiący. No, bo jeżeli "to czego szukamy" nie równa się "1", a np. "x"?

    OdpowiedzUsuń